We will continue to monitor as the provider fix rolls out.
Posted Feb 19, 2026 - 18:12 UTC
Identified
We are receiving occasional reports that some users still cannot log in. We will continue to monitor as the provider fix rolls out.
Posted Feb 19, 2026 - 17:14 UTC
Monitoring
The provider has confirmed a fix and everything is operational.
Posted Feb 19, 2026 - 16:55 UTC
Identified
We have been informed that a fix is rolling out and the situation is improving rapidly
Posted Feb 19, 2026 - 16:43 UTC
Investigating
We are tracking an issue with a major internet infrastructure provider that may be the causing Venice as well as other sites not to respond in a timely fashion.
Posted Feb 19, 2026 - 16:42 UTC
This incident affected: Venice App and Venice API.