Our crypto API provider is currently experience an outage related to ongoing issues with their cloud provider (AWS). The site appears functioning but some

Incident Report for Venice

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 23:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 23:13 UTC

Update

In addition to issues with our crypto API provider, our database has been having issues and is causing failures with our API and slower App performance. Again, these issues are related to a major cloud incident that is affecting a wide range of internet services outside of Venice.
Posted Oct 20, 2025 - 19:43 UTC

Update

The situation has improved significantly but will leave this incident open as we are still seeing occasional errors
Posted Oct 20, 2025 - 18:08 UTC

Investigating

Our crypto API provider is currently experience an outage related to ongoing issues with their cloud provider which is affecting a range of internet services outside of Venice. Crypto related operations may be degraded or non functional.
Posted Oct 20, 2025 - 17:06 UTC
This incident affected: Venice App and Venice API.