Several image models are slow or unresponsive

Incident Report for Venice

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 23:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2026 - 23:08 UTC

Identified

We have identified that the issue is with one of our infrastructure providers. We have added more capacity elsewhere to improve image throughput and reduce timeouts.
Posted Feb 17, 2026 - 22:51 UTC

Investigating

We are investigating an issue with several of our image models which is resulting in slow or unresponsive image generation
Posted Feb 17, 2026 - 22:15 UTC
This incident affected: Venice App and Venice API.